<!doctype html>
<html lang="en-GB">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>Revenge of the Sith end battle was &#8220;most fun&#8221; for Hayden Christensen | The Digital Fix</title>
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-permutive/assets/style.css"><script src="https://www.thedigitalfix.com/wp-content/plugins/legion-permutive/assets/app.js"></script><script src="https://www.thedigitalfix.com/wp-content/plugins/legion-single-action-widget/public/js/legion-single-action-widget-public.js?cachebust=2"></script><script src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/js/app.5378ab93.min.js"></script><script src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/js/scroll.5378ab93.min.js"></script> <script>
            window.addEventListener('DOMContentLoaded', initSidebarScript);
            function initSidebarScript () {
                if (window.innerWidth < 901) return;

                const sidebar = document.getElementById('sidebar');
                
                const bottomOfViewport = 0;
                window.sidebarEnd = 0;
                window.docked = false;
                

                window.addEventListener('scroll', detectEndOfSidebar);
            }

            function hasClass(element,cls) {
                if (element.className.indexOf(cls) > -1) {
                    return true;
                } 
                return false;
            }

            function detectEndOfSidebar () {
                const sidebarBackground = document.getElementById('sidebar-background');
                const stickyRail = document.getElementsByClassName('sticky_rail600')[0];
                if (hasClass(document.getElementsByTagName('body')[0], 'ads-disabled')) { 
                    var sidebarHeight = document.getElementsByTagName("body")[0].offsetHeight;
                } else {
                    var sidebarHeight = document.getElementsByTagName("body")[0].offsetHeight - 300;
                }
                sidebarBackground.style.height =  sidebarHeight + 'px';


                // Limit executions per second:
                let currentTime = new Date().getTime();

                if ( window.lastSidebarDetection && currentTime < window.lastSidebarDetection + 100 ) {
                    return;
                }

                window.lastSidebarDetection = currentTime;

                
                if ( window.sidebarEnd === 0 ) {
                    // Captured only once to enable upward scrolling
                    window.sidebarEnd = sidebar.offsetHeight + sidebar.offsetTop + 300;
                }

                bottomOfViewport = window.scrollY + window.innerHeight;

                // Detect scroll positions:
                if (hasClass(document.getElementsByTagName('body')[0], 'ads-disabled')) {
                    if( bottomOfViewport >= sidebarEnd && hasClass(document.getElementsByTagName('body')[0], 'ads-disabled')) { 
                        dockSidebar(0 - (sidebar.clientHeight - window.innerHeight))
                    } else {
                        undockSidebar();
                    }
                } else {
                    if( bottomOfViewport >= sidebarEnd - 330 && !hasClass(document.getElementsByTagName('body')[0], 'ads-disabled')) { 
                        dockSidebar(0 - (sidebar.clientHeight - window.innerHeight))
                    } else {
                        undockSidebar();
                    }
                }
            }

            function dockSidebar (distance) {
                window.docked = true;
                sidebar.style = `position: fixed; top: ${distance}px;`;
            }

            function undockSidebar () {
                if (window.docked) {
                    window.docked = false;
                    sidebar.removeAttribute('style');
                }           
            }

           
        </script>
<link rel="preconnect" href="https://cdn.consentmanager.mgr.consensu.org/" crossorigin>
<link rel="preconnect" href="https://mb.moatads.com">
<link rel="preconnect" href="https://tags.bkrtx.com">
<link rel="preconnect" href="https://securepubads.g.doubleclick.net/" crossorigin>
<link rel="preconnect" href="https://c.amazon-adsystem.com/" crossorigin>
<link rel="canonical" href="https://www.thedigitalfix.com/star-wars/hayden-christensen-revenge-of-the-sith">
<meta name="description" content="Hayden Christensen, who recently returned to the Star Wars universe as Anakin Skywalker/Darth Vader, has talked about filming Revenge of the Sith">
<meta name="twitter:image" content="https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight.jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta property="og:site_name" content="The Digital Fix">
<meta property="og:type" content="website">
<meta property="og:description" content="Hayden Christensen, who recently returned to the Star Wars universe as Anakin Skywalker/Darth Vader, has talked about filming Revenge of the Sith">
<meta property="og:title" content="Revenge of the Sith end battle was &#8220;most fun&#8221; for Hayden Christensen">
<meta property="og:url" content="https://www.thedigitalfix.com/star-wars/hayden-christensen-revenge-of-the-sith">
<meta property="og:image" content="https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight.jpeg">
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="robots" content="max-image-preview:large">
<script>var site = {"ajax_url":"https:\/\/www.thedigitalfix.com\/wp-admin\/admin-ajax.php"};</script>
<style>html>body{padding-top:var(--navbarHeight,60px)}@media screen and (min-width:900px){header.banner{position:fixed!important;top:0}html>body{padding-top:var(--navbarHeight,60px)}.bfa-loaded #nn_astro_wrapper{min-height:0;height:0}body.bfa-loaded{margin-top:0!important}#nn_astro_wrapper{height:250px;vertical-align:middle;text-align:center;position:relative;background:#fff;width:970px;margin:0 auto}#nn_astro_wrapper #nn_lb1{transform:translate(-50%,-50%);top:50%;left:50%;position:absolute}#nn_astro_wrapper #nn_lb1.lb-sticky{transform:none;top:60px;position:absolute;position:fixed;z-index:1000;left:calc(50% - 485px)}#nn_skin,#nn_skinl,#nn_skinr{position:fixed!important;top:0!important;padding-top:var(--navbarHeight,60px)!important}}.bfa-loaded #wpadminbar,.bfa-loaded.bfa-mini #wpadminbar{z-index:9999999999}body:not(.celtra-loaded):not(.bfa-loaded):not(.bfa-sticky-leaderboard) .celtra-reveal-header-sticky.banner{position:fixed!important}</style>
<script>window.AdSlots = { cmd: [], disableScripts: ['gpt','bk'], renderOnFirstLoad: false, divCheck: false }</script>
<script async src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src="https://kumo.network-n.com/dist/app.js" site="the-digital-fix"></script>
<script type="text/javascript">var narrativid = 'thedigitalfix';var amazon_ukid = 'digital.fix-21';var amazon_usid = 'digital.fix-20';var affiliate_windowid = '616453';var skimlinksid = '97464X1651631';var disclaimertext='Network N earns commission from qualifying purchases via Amazon Associates and other programs.';var constellation_key='0bd024c20270d6ceaebf6dedf2abcdae';var constellation_site='thedigitalfix';var constellation_url='https://constellationv2.network-n.com';var affiliatedisclaimer = false;var new_affiliates_defaultRegion = 'USD';var new_affiliates_defaultCurrency = '$';var new_affiliates_maxEmbeds = 3;var possibleInvalidNetworkIds = new Array('30372','51552','dvdtimes01','thedigitalfix-21','thedvdforums-21','thedvdforums01','thedvdforums-20','616453','pcgamesn0f-21','pcgamesn-20','97464X1552553','digital.fix-21'); </script> <script type="text/javascript">
		(function(window, document, account) {
			window.skimlinks_exclude = ["shop-links.co", "shop-edits.co"];
			window.NRTV_EVENT_DATA = { donotlink: true };
			var b = document.createElement("script");
			b.type = "text/javascript";
			b.src = "https://static.narrativ.com/tags/" + account + ".js";
			b.async = true;
			var a = document.getElementsByTagName("script")[0];
			a.parentNode.insertBefore(b,a);
		})(window, document, narrativid);
	</script>
<style>body #site_wrap .post_footer .BeOpVSlot, body .next_page_placeholder .post_footer .BeOpVSlot{display:inline} body #site_wrap .post_footer .BeOpWidget+div, body #site_wrap .post_footer .BeOpWidget+p, body .next_page_placeholder .post_footer .BeOpWidget+div,  body .next_page_placeholder .post_footer .BeOpWidget+p{margin-top:35px}</style>
<script id="schema-plugin" data-page-type="post" type="application/ld+json">{"@context":"https://schema.org","@graph":[{"@type":"NewsArticle","author":{"@type":"Person","@id":"https://www.thedigitalfix.com/wp-content/uploads/2022/01/v2-charlotte-digital-fix.jpg","name":"Charlotte Colombo","image":{"@type":"ImageObject","@id":"https://www.thedigitalfix.com/wp-content/uploads/2022/01/v2-charlotte-digital-fix.jpg#image","inLanguage":"en-GB","url":"https://www.thedigitalfix.com/wp-content/uploads/2022/01/v2-charlotte-digital-fix.jpg","contentUrl":"https://www.thedigitalfix.com/wp-content/uploads/2022/01/v2-charlotte-digital-fix.jpg","caption":"Charlotte Colombo"},"description":"Charlotte is a chronically online Staff Writer who knows an unhealthy amount about pop culture, streaming services, tech and anything that can be meme'd. She passionately believes that Sharpay is the true hero of High School Musical and has previously written for Insider, The Independent, New Statesman and Digital Spy, among others.","sameAs":["https://twitter.com/colombochar"],"url":"https://www.thedigitalfix.com/author/charlotte-colombo"},"headline":"Revenge of the Sith end battle was &#8220;most fun&#8221; for Hayden Christensen","datePublished":"2022-06-16T16:37:25+00:00","dateModified":"2022-06-16T16:37:25+00:00","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.thedigitalfix.com/star-wars/hayden-christensen-revenge-of-the-sith"},"wordCount":304,"publisher":{"@type":"Organization","@id":"https://www.thedigitalfix.com/#organization","name":"The Digital Fix","url":"https://www.thedigitalfix.com","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.thedigitalfix.com/#logo","inLanguage":"en-GB","url":"https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/apple-touch-icon.png","contentUrl":"https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/apple-touch-icon.png","width":192,"height":192,"caption":"The Digital Fix logo"},"image":"https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/apple-touch-icon.png"},"image":{"@type":"ImageObject","@id":"https://www.thedigitalfix.com/star-wars/hayden-christensen-revenge-of-the-sith#primaryimage","inLanguage":"en-GB","url":"https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight.jpeg","contentUrl":"https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight.jpeg","width":1920,"height":1080,"caption":"Revenge of the Sith end battle was \"most fun\" for Hayden Christensen"},"thumbnailUrl":"https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight.jpeg","articleSection":["Star Wars","Science fiction"],"dateline":"Thursday, June 16th, 2022","articleBody":"With the Star Wars prequel movies holding a special place in countless peoples' heart, many were delighted when it was announced that Ewan McGregor would be returning to play his iconic role as the Jedi Knight in a standalone sci-fi series. But what made this announcement even better was the fact that he wouldn't be returning alone: Hayden Christensen, who played Anakin Skywalker/Darth Vader, would also be returning. In a new Star Wars video featurette, entitled 'Memory Lane,' the pair reflected on their favourite moments on returning to the Star Wars universe and filming the iconic science fiction movies. \"There's many great memories, it's hard to pick a favourite,\" Christensen said. \"I have so many fond memories,\" McGregor added. \"It felt so good to come back to it, didn’t it? It really did. Before we started shooting [Episode III] we did so much fight training and rehearsals.\" The discussion naturally turned to the pair's iconic fight scene in Revenge of the Sith.. \"It was incredible,\" McGregor recalled. \"So then, of course, in Episode III, we had our big fight scene,\" Christensen recalled. \"That was the most fun for me. I think we both took it really seriously, too, so we were having so much fun, but it was really intense and rewarding.\"  Talking about reuniting all those years later, McGregor said, \"That day we both walked on set was quite something else.\" Christensen added, \"When I got the call that I was gonna be able to come back with you, reunited as these characters, it was mind-blowing.\" Obi-Wan Kenobi is now available to view on the streaming service Disney Plus along with all the Star Wars movies."},{"@type":"BreadcrumbList","itemListElement":[{"@context":"https://schema.org","@type":"ListItem","position":1,"item":{"@id":"https://www.thedigitalfix.com/","name":"Home"}},{"@context":"https://schema.org","@type":"ListItem","position":2,"item":{"@id":"https://www.thedigitalfix.com/star-wars","name":"Star Wars"}},{"@context":"https://schema.org","@type":"ListItem","position":3,"item":{"@id":"https://www.thedigitalfix.com/star-wars/hayden-christensen-revenge-of-the-sith","name":"Revenge of the Sith end battle was &#8220;most fun&#8221; for Hayden Christensen"}}]}]}</script>

<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0" />
<meta name="parsely-title" content="Revenge of the Sith end battle was &#8220;most fun&#8221; for Hayden Christensen" />
<meta name="parsely-link" content="https://www.thedigitalfix.com/star-wars/hayden-christensen-revenge-of-the-sith" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-150x150.jpeg" />
<meta name="parsely-pub-date" content="2022-06-16T16:37:25Z" />
<meta name="parsely-section" content="Star Wars" />
<meta name="parsely-author" content="Charlotte Colombo" />
<meta name="parsely-tags" content="News-Cell" />

<script>
    window.addEventListener('NextPageInView', preventNullNextPages);

    function preventNullNextPages (eventData) {
      let finalElNum = window.InfiniteScroll.pageHistory[window.InfiniteScroll.pageHistory.length - 1].$el.dataset.pageId;
      let previousElNum = window.InfiniteScroll.pageHistory[window.InfiniteScroll.pageHistory.length - 2].$el.dataset.pageId;

      if (
        (finalElNum && previousElNum) &&
        (previousElNum >= finalElNum)
      ) {
        document.getElementsByClassName('js-ifs-nextpage')[0].remove();

        window.InfiniteScroll.homeFlowCounter = finalElNum;
        window.InfiniteScroll.currentOrderIndex = finalElNum;
        window.InfiniteScroll.currentPageIndex = finalElNum;
        window.InfiniteScroll.pageCounter = finalElNum;
      }
    }
  </script>
<link rel="preconnect" href="https://use.typekit.net"><style>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</style>
<link rel="preload" as="image" href="/wp-content/themes/thedigitalfix/dist/images/thedigitalfix.svg" />
<link rel="preload" as="image" href="/wp-content/themes/thedigitalfix/dist/images/search_icon.svg" />
<link rel="preload" as="image" href="https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight.jpeg" imagesrcset="https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-740x416.jpeg 740w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-768x432.jpeg 768w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-900x506.jpeg 900w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-580x326.jpeg 580w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-297x167.jpeg 297w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-183x103.jpeg 183w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-280x158.jpeg 280w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-263x148.jpeg 263w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-213x120.jpeg 213w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-233x132.jpeg 233w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-860x485.jpeg 860w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-175x99.jpeg 175w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-330x185.jpeg 330w" imagesizes="(max-width: 900px) 100vw, 900px" />
<link rel="apple-touch-icon" href="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/android-icon-48x48.png">
<link rel="shortcut icon" href="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/favicon.ico"> <link rel="alternate" type="application/rss+xml" title="The Digital Fix" href="/mainrss.xml" />
<meta property="fb:pages" content="337635522287" /> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-5484062-23"></script>
<script>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());



    gtag('config', 'UA-5484062-23', {
    'custom_map': {
        'dimension1': 'bluekai_id',
        'dimension3': 'content_id',
        'dimension4': 'section',
        'dimension8': 'pagetype',
        'dimension12': 'associatedip',
        'dimension15': 'featuredimage',
        'dimension16': 'thumbnail'
    },
    'content_id': '34077',
    'section': 'movies',
    'pagetype': 'article',
    'associatedip': 'star-wars',
    'featuredimage': 'https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight.jpeg',
    'thumbnail': 'https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-330x185.jpeg'
  });


__bluekai_data_sent = false;
function receiveMessage(event) {
  if (event.origin === 'http://tags.bluekai.com' || event.origin === 'https://stags.bluekai.com') {
    if (__bluekai_data_sent === false && typeof event.data !== 'undefined' && event.data.source === 'bluekai') {
      gtag('event', 'bluekai_id_dimension', {'bluekai_id': event.data.bluekaiId});
      __bluekai_data_sent = true;
    }
  }
}

addEventListener('message', receiveMessage, false);


</script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-TRRTR8K');</script>

</head>
<body class="post-template-default single single-post postid-34077 single-format-standard wp-featherlight-captions hayden-christensen-revenge-of-the-sith tdf-default-template">
<script>
  window.beOpAsyncInit = function() {
    BeOpSDK.init({
      account: "60afb059b5e58a6db0d995c2",
      refreshExistingSlots: false
    });
    BeOpSDK.watch();
  };
</script>
<script async src="https://widget.beop.io/sdk.js"></script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TRRTR8K"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<header class="banner">
<div class="container" data-nosnippet>
<div><a class="brand" href="https://www.thedigitalfix.com/">The Digital Fix</a></div> <nav class="nav-primary">
<div id="menu_toggle"><input type="checkbox" /><span class="hamburger"></span><div class="menu-primary_navigation-container"><ul id="menu-primary_navigation" class="nav"><li class="menu-item"><a href="/tv">TV</a></li>
<li class="menu-item"><a href="/movies">Movies</a></li>
<li class="menu-item"><a href="/tech">Tech</a></li>
<li class="menu-item"><a href="https://forums.thedigitalfix.com/">Forum</a></li>
<li class="menu-header-community all-exclude menu-item menu-item-has-children main-dropdown"><a>Community</a>
<ul class="sub-menu">
<li class="community__twitter menu-item"><a href="https://twitter.com/thedigitalfix">Twitter</a></li>
<li class="community__facebook menu-item"><a href="https://www.facebook.com/thedigitalfix/">Facebook</a></li>
<li class="community__instagram menu-item"><a href="https://www.instagram.com/thedigitalfix/">Instagram</a></li>
</ul>
</li>
<li class="all-exclude menu-item menu-item-has-children main-dropdown"><a>More</a>
<ul class="sub-menu">
<li class="menu-item"><a href="https://www.thedigitalfix.com/about-us">About Us</a></li>
<li class="menu-item"><a href="/archives/">Archive</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/pitch-to-us">Pitch to Us</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/careers">Careers</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/terms-conditions">Terms &#038; Conditions</a></li>
<li class="nn-cmp-show menu-item"><a href="/privacy-policy">Cookie Policy</a></li>
</ul>
</li>
<li class="mobile-footer"><a href="">A <img src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/NetworkN_white.svg">Brand</a></li></ul></div></div> </nav>
<nav class="nav-secondary">
<a href="https://www.thedigitalfix.com/search" class="header-search"></a>
<a href="https://www.network-n.com" target="_blank" rel="noopener" class="network-logo">Network-N</a>
</nav>
<div id="header-searchbox"><form method="get" action="https://www.thedigitalfix.com/" id="header-search-form"><input id="header-search-input" name="s" id="term" /></form></div>
<div id="header-search-suggestions"></div>
</div>
</header>
<div id="nn_astro_wrapper"><div class="nn_bb ad" id="nn_lb1"></div></div><div class="ad" id="nn_lb2"></div><div class="ad" id="nn_mobile_lb1"></div><div id="site_wrap" class="" role="document">
<article class="post-34077 post type-post status-publish format-standard has-post-thumbnail hentry category-star-wars">
<header class="article-header">
<div id="article-details">
<h1 class="entry-title">Revenge of the Sith end battle was &#8220;most fun&#8221; for Hayden Christensen</h1>
<div class="fader"></div>
</div>
<div class="article-featured-image"><img width="900" height="506" src="https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-900x506.jpeg" class="webfeedsFeaturedVisual type:primaryImage wp-post-image" alt="revenge of the sith fight" title="Revenge of the Sith end battle was &#8220;most fun&#8221; for Hayden Christensen" srcset="https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-900x506.jpeg 900w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-740x416.jpeg 740w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-768x432.jpeg 768w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-580x326.jpeg 580w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-297x167.jpeg 297w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-183x103.jpeg 183w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-280x158.jpeg 280w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-263x148.jpeg 263w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-213x120.jpeg 213w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-233x132.jpeg 233w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-860x485.jpeg 860w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-175x99.jpeg 175w, https://www.thedigitalfix.com/wp-content/uploads/2022/06/revenge-of-the-sith-fight-330x185.jpeg 330w" sizes="(max-width: 900px) 100vw, 900px"></div> </header>
<div class="entry-content">
<p class="p1">With the <a href="https://www.thedigitalfix.com/star-wars" rel="noopener">Star Wars</a> prequel movies holding a special place in&nbsp;countless peoples&rsquo; heart, many were delighted when it was announced that Ewan McGregor would be returning to play his iconic role as the Jedi Knight in&nbsp;a standalone&nbsp;<a class="text_link" href="https://www.thedigitalfix.com/best-sci-fi-series" target="_blank" rel="noopener noreferrer">sci-fi series</a>.
</p><div class="nn_mobile_mpu_wrapper"></div><p class="p1">But what made this announcement even better was the fact that he wouldn&rsquo;t be returning alone: Hayden Christensen, who played Anakin Skywalker/<a href="https://www.thedigitalfix.com/star-wars/darth-vader-explained" rel="noopener">Darth Vader</a>, would also be returning. In a new&nbsp;Star Wars&nbsp;video <a href="https://www.youtube.com/watch?v=d6Uz3B0_fk8" rel="noopener">featurette</a>, entitled &lsquo;Memory Lane,&rsquo; the pair reflected on their favourite moments on returning to the Star Wars universe and filming the iconic <a href="https://www.thedigitalfix.com/best-science-fiction-movies" rel="noopener">science fiction movies</a>.
</p><p class="p1">&ldquo;There&rsquo;s many great memories, it&rsquo;s hard to pick a favourite,&rdquo; Christensen said. &ldquo;I have so many fond memories,&rdquo; McGregor added. &ldquo;It felt so good to come back to it, didn&rsquo;t it? It really did. Before we started shooting [Episode III] we did so much fight training and rehearsals.&rdquo; The discussion naturally turned to&nbsp;the pair&rsquo;s iconic fight scene in Revenge of the Sith.. &ldquo;It was incredible,&rdquo; McGregor recalled.
</p><div class="legion_primiswrapper"><div id="nn_player"></div></div>
<p class="p1">&ldquo;So then, of course, in Episode III, we had our big fight scene,&rdquo; Christensen recalled. &ldquo;That was the most fun for me. I think we both took it really seriously, too, so we were having so much fun, but it was really intense and rewarding.&rdquo;
</p><div class="new_affiliate_embed" contenteditable="false" data-usd-type="pricecomparison" data-gbp-type="pricecomparison" data-usd-ean="B00513HWJI" data-usd-title="Revenge of the Sith: Star Wars: Episode III" data-usd-image="https://m.media-amazon.com/images/I/51d-KKwPpOL._SL500_.jpg" data-gbp-ean="B000FCK29M" data-gbp-title="Revenge of the Sith: Illustrated Screenplay: Star Wars: Episode III (Star Wars - Legends)" data-gbp-image="https://m.media-amazon.com/images/I/51EF3VKG0dL._SL500_.jpg"></div>
<p class="p1">Talking about reuniting all those years later, McGregor said, &ldquo;That day we both walked on set was quite something else.&rdquo; Christensen added, &ldquo;When I got the call that I was gonna be able to come back with you, reunited as these characters, it was mind-blowing.&rdquo;
</p><p class="p1">Obi-Wan Kenobi is now available to view on the <a href="https://www.thedigitalfix.com/best-streaming-services" rel="noopener">streaming service</a>&nbsp;Disney Plus along with all the <a href="https://www.thedigitalfix.com/star-wars/movies-in-order" rel="noopener">Star Wars&nbsp;movies</a>.
</p><div class="left-column">
<section id="author-and-social">
<img alt="" class="avatar avatar-80 photo avatar-default lazyload" height="80" width="80" data-src="https://www.thedigitalfix.com/wp-content/uploads/2022/01/v2-charlotte-digital-fix.jpg"> <a class="author-name" href="https://www.thedigitalfix.com/author/charlotte-colombo" rel="noopener">Charlotte Colombo</a>
<p class="job-title">Staff Writer</p>
<p class="updated-date">Updated: Jun 16, 2022</p>
<p class="social-call"><b>Follow us</b></p>
<hr>
<p class="social-icons"><a class="meta-icon" target="_blank" href="https://www.facebook.com/thedigitalfix/" rel="noopener"><img width="20" height="20" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/icons/fb_white.svg"></a><a class="meta-icon" target="_blank" href="https://twitter.com/thedigitalfix" rel="noopener"><img width="20" height="20" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/icons/tw_white.svg"></a><a class="meta-icon" target="_blank" href="https://www.instagram.com/thedigitalfix" rel="noopener"><img width="20" height="20" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/icons/ig_white.svg"></a><a class="meta-icon" target="_blank" href="https://www.youtube.com/channel/UCelDv5XCqbEQbGT_MvsJ_Ug" rel="noopener"><img width="20" height="20" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/icons/yt_white.svg"></a></p>
</section>
<section id="taxonomy">
<b class="category_title"><a href="https://www.thedigitalfix.com/star-wars" rel="noopener">Star Wars</a></b>
<div class="category_facets">
<a href="https://www.thedigitalfix.com/genre/science-fiction" rel="noopener">Science fiction</a>
<a href="https://www.thedigitalfix.com/other/tv" rel="noopener">TV</a>
<a href="https://www.thedigitalfix.com/other/movies" rel="noopener">Movies</a>
</div>
</section>
<section id="read-next">
<b>Read next</b>
<hr>
<a href="https://www.thedigitalfix.com/star-wars/samuel-l-jackson-star-wars-mcu-oscar" rel="noopener">
<article>
<img alt="" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/uploads/2022/06/star-wars-mace-windu-297x167.jpg"> <span class="title">Samuel L Jackson prefers Star Wars and the MCU to Oscar movies</span>
</article>
</a>
</section>
<section id="get-involved">
<b>Get involved</b>
<hr>
Continue the conversation over on
<a href="https://forums.thedigitalfix.com/forums/" rel="noopener">The Digital Fix Forum</a>
</section>
</div>
</div>
</article>
<div class="post_footer">
<p class="social_cta">
Be part of the conversation by heading over to our <a href="https://www.facebook.com/thedigitalfix/">Facebook page</a>. To stay up to date with all the latest entertainment news, guides, opinion, and reviews, follow The Digital Fix on <a href="https://twitter.com/thedigitalfix">Twitter</a>.<br />
<br />
We sometimes include relevant affiliate links in articles from which we earn a small commission. Any stated prices are correct at the time of publication. For more information, click <a href="https://www.thedigitalfix.com/terms-and-conditions">here</a>. </p>
<div class="BeOpWidget" data-name="below-article"></div><script class="hidden_meta" id="permutive-schema" data-page-type="post" type="application/ld+json">{"schema":{"page":{"content":{"headline":"Revenge of the Sith end battle was &#8220;most fun&#8221; for Hayden Christensen","type":"news","category":"star-wars"},"user":{"loginstatus":false},"game":{"publisher":"","genre":"Science fiction","title":"Star Wars","genres":["Science fiction","TV","Movies"]}}}}</script><div class="disclaimer">
We sometimes include relevant affiliate links in articles from which we earn a small commission.
For more information, <a href="/terms-and-conditions">click here</a>.
</div> </div>
<script src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/js/posts.5378ab93.min.js"></script><div class="OUTBRAIN" data-src="https://www.thedigitalfix.com/star-wars/hayden-christensen-revenge-of-the-sith" data-widget-id="AR_1"></div> <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script><script>window.addEventListener("NextPageInView", function(e) { console.log("Outbrain Refresh"); OBR.extern.researchWidget(); });</script>
</div>
<div id="sidebar-background"></div>
<section id="sidebar"><span class="sidebar-heading">Trending in <b>Movies</b></span>
<a href="/the-shawshank-redemption/the-shining-easter-egg-never-noticed">
<article class="sidebar-preview trending">
<div class="thumbnail"><img src="https://www.thedigitalfix.com/wp-content/uploads/2022/06/shawshank-redemption-the-shining-easter-egg-330x185.jpg" alt=""></div>
<span class="title"><span>1</span>The Shawshank Redemption has a Shining easter egg you’ve never noticed </span>
</article>
</a>
<a href="/mayans-mc-season-5">
<article class="sidebar-preview trending">
<span class="title"><span>2</span>Mayans MC season 5 release date speculation, trailer, cast, and more </span>
</article>
</a>
<a href="/clint-eastwood/spike-lee-feud-settled-at-a-basketball-game">
<article class="sidebar-preview trending">
<span class="title"><span>3</span>Clint Eastwood and Spike Lee’s feud was settled at a basketball game </span>
</article>
</a>
<div class="sticky_rail600 inlinerail"><div class="nn_inline_mp ad" id="nn_mpu1"></div></div>
<span class="sidebar-heading">Latest in <b>Movies</b></span>
<a href="/revenge-of-the-sith-end-battle-was-most-fun-for-hayden-christensen">
<article class="sidebar-preview latest">
<span class="title">Revenge of the Sith end battle was "most fun" for Hayden Christensen</span>
</article>
</a>
<a href="/fast-and-furious-star-always-wanted-a-motorcycle-but-wasnt-allowed">
<article class="sidebar-preview latest">
<span class="title">Fast and Furious star always wanted a motorcycle, but wasn't allowed</span>
</article>
</a>
<a href="/tom-hardy-is-co-writing-venom-3">
<article class="sidebar-preview latest">
<span class="title">Tom Hardy is co-writing Venom 3</span>
</article>
</a>
<a href="/why-toy-storys-little-green-men-arent-in-lightyear">
<article class="sidebar-preview latest">
<span class="title">Why Toy Story's Little Green Men aren't in Lightyear</span>
</article>
</a>
<a href="/mayans-mc-showrunner-says-ez-is-now-all-in">
<article class="sidebar-preview latest">
<span class="title">Mayans MC showrunner says EZ is now "all in"</span>
</article>
</a>
<div class="sticky_rail600"><div class="ad" id="nn_mpu2"></div></div>
<section class="sidebar-footer">
A <img class="brand" src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/NetworkN_white.svg"> brand
</section>
</section>
<footer class="site-footer">
<div class="container">
<div class="footer-brand">
<span class="footer-copyright">&copy; 2022</span>
<span class="brand-networkn">Powered by Network-N</span>
</div>
<ul class="footer-links">
<li><a href="https://www.thedigitalfix.com/terms-and-conditions">Terms and conditions</a>
<li><a href="https://www.thedigitalfix.com/about-us">About us</a>
<li><a href="https://www.thedigitalfix.com/careers">Careers</a>
</ul>
</div>
</footer>
<script>
    var constellation_deals_formats = 'Headphones|Home Cinema & Entertainment Tech|DVD & Blu-Ray|DVD|TVs';
    var constellation_deals_rows = '10';
    var constellation_deals_mindiscount = '1';
    </script>
<script src="https://constellationv2.network-n.com/shared/constellation-deals.js?cacheflag=10"></script>
<link rel="stylesheet" href="https://constellationv2.network-n.com/shared/constellation-deals.css?cacheflag=10" />
<div class="nn_skinl ad" id="nn_skinl"></div><div class="nn_skinr ad" id="nn_skinr"></div><link rel="stylesheet" href="https://constellationv2.network-n.com/shared/constellation-core.css?cacheflag=20220606"><script defer src="https://constellationv2.network-n.com/shared/constellation-core.js?cacheflag=20220606"></script><div class="js-ifs-nextpage articles_container">
<div class="loading"><div class="loading-text"></div>
<svg class="spinner" viewBox="0 0 50 50"><circle class="path" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg>
</div>
</div>

<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="thedigitalfix.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<script>window.disableFlowAds = true;</script> <script type="text/javascript">
    var main_css = document.createElement('link');
    main_css.rel = 'stylesheet';
    main_css.href = 'https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/styles/main.5378ab93.css';
    main_css.type = 'text/css';
    let linkTags = document.getElementsByTagName('link');
    var main_css_target = linkTags[(linkTags.length)];
    var main_css_target = document.getElementsByTagName('link')[0];
    main_css_target.parentNode.insertBefore(main_css, main_css_target);
    </script>
<style>
        #nn_skinr,
        #nn_skinl {            
            left: 50%;
            margin-top: 20px;
            margin-left: -970px!important;
            z-index: 100;
            padding-top: 80px;
        }
        #nn_skinr {
            margin-left: 650px!important;
        }
        #nn_skinl {
            width: 300px;
            text-align: right;  
        }
        
    </style>
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-advertising-atlasastro/dist/css/app.60419458.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/patch-notes/patch-notes.css?cb_20220616">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/post-types.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/jquery-ui.min.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/nn-images.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/featherlight/featherlight.gallery.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/featherlight-overrides.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/css/wp-featherlight.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/gallery.css">
<script type='text/javascript'>
/* <![CDATA[ */
var teadsConfig = {"page":"","placement":""};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-advertising-atlasastro/dist/js/app.60419458.min.js"></script>
<script src="https://www.thedigitalfix.com/wp-includes/js/jquery/jquery.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-includes/js/jquery/jquery-migrate.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/patch-notes/patch-notes.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/post-types.js?nc140420"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-includes/js/jquery/ui/core.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/jquery-ui.min.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var legion_games = {"ajax_url":"https:\/\/www.thedigitalfix.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/legion-games.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/mce-table-buttons/mobile_tables.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ifs_data = {"target_container":".js-ifs-nextpage","ordering":{"home":["home-normal"],"game":["game-normal"],"article":["19114","600","16626","14687","16413","article-specified","game-normal"]},"flow_type":"article","author_name":"","pid":"34077","paged":"2","homepage":"","search_keyword":"","gametype":"","month":"0","year":"0","ignore_post_ids":[]};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/new-infinite-scroll/dist/js/app.71bbd3d3.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/nn-images.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-pagespeed/js/lazysizes.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/jquery.detect_swipe.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/featherlight.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/featherlight.gallery.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/wpFeatherlight.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/main-356d78ed96.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/custom-6ecfacf2bc.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/mobile-fbad030ed9.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/feature-video-8e2531fa9c.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/video-759f4d116e.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/./js/main.5378ab93.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/hammer.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/gallery.js"></script>
</body>
</html>
