<!doctype html>
<html lang="en-GB">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>David Harbour&#8217;s new action movie compared to Die Hard | The Digital Fix</title>
<link rel="stylesheet" href="https://constellation.network-n.com/shared/constellation-core.css?cacheflag=20210331"><script src="https://constellation.network-n.com/shared/constellation-core.js?cacheflag=20210331"></script><link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-permutive/assets/style.css"><script src="https://www.thedigitalfix.com/wp-content/plugins/legion-permutive/assets/app.js"></script><script src="https://www.thedigitalfix.com/wp-content/plugins/legion-single-action-widget/public/js/legion-single-action-widget-public.js?cachebust=2"></script><script src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/js/app.f8c04b2e.min.js"></script><script src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/js/scroll.f8c04b2e.min.js"></script> <script>
            window.addEventListener('DOMContentLoaded', initSidebarScript);
            function initSidebarScript () {
                if (window.innerWidth < 901) return;

                const sidebar = document.getElementById('sidebar');
                
                const bottomOfViewport = 0;
                window.sidebarEnd = 0;
                window.docked = false;
                

                window.addEventListener('scroll', detectEndOfSidebar);
            }

            function hasClass(element,cls) {
                if (element.className.indexOf(cls) > -1) {
                    return true;
                } 
                return false;
            }

            function detectEndOfSidebar () {
                const sidebarBackground = document.getElementById('sidebar-background');
                const stickyRail = document.getElementsByClassName('sticky_rail600')[0];
                if (hasClass(document.getElementsByTagName('body')[0], 'ads-disabled')) { 
                    var sidebarHeight = document.getElementsByTagName("body")[0].offsetHeight;
                } else {
                    var sidebarHeight = document.getElementsByTagName("body")[0].offsetHeight - 300;
                }
                sidebarBackground.style.height =  sidebarHeight + 'px';


                // Limit executions per second:
                let currentTime = new Date().getTime();

                if ( window.lastSidebarDetection && currentTime < window.lastSidebarDetection + 100 ) {
                    return;
                }

                window.lastSidebarDetection = currentTime;

                
                if ( window.sidebarEnd === 0 ) {
                    // Captured only once to enable upward scrolling
                    window.sidebarEnd = sidebar.offsetHeight + sidebar.offsetTop + 300;
                }

                bottomOfViewport = window.scrollY + window.innerHeight;

                // Detect scroll positions:
                if (hasClass(document.getElementsByTagName('body')[0], 'ads-disabled')) {
                    if( bottomOfViewport >= sidebarEnd && hasClass(document.getElementsByTagName('body')[0], 'ads-disabled')) { 
                        dockSidebar(0 - (sidebar.clientHeight - window.innerHeight))
                    } else {
                        undockSidebar();
                    }
                } else {
                    if( bottomOfViewport >= sidebarEnd - 330 && !hasClass(document.getElementsByTagName('body')[0], 'ads-disabled')) { 
                        dockSidebar(0 - (sidebar.clientHeight - window.innerHeight))
                    } else {
                        undockSidebar();
                    }
                }
            }

            function dockSidebar (distance) {
                window.docked = true;
                sidebar.style = `position: fixed; top: ${distance}px;`;
            }

            function undockSidebar () {
                if (window.docked) {
                    window.docked = false;
                    sidebar.removeAttribute('style');
                }           
            }

           
        </script>
<link rel="preconnect" href="https://cdn.consentmanager.mgr.consensu.org/" crossorigin>
<link rel="preconnect" href="https://mb.moatads.com">
<link rel="preconnect" href="https://tags.bkrtx.com">
<link rel="preconnect" href="https://securepubads.g.doubleclick.net/" crossorigin>
<link rel="preconnect" href="https://c.amazon-adsystem.com/" crossorigin>
<link rel="canonical" href="https://www.thedigitalfix.com/violent-night/david-harbour-new-action-movie-die-hard">
<meta name="description" content="During CinemaCon fans saw the first look at David Harbour&#039;s new action movie, Violent Night, which the star directly compared to the holiday classic - Die Hard ">
<meta name="twitter:image" content="https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard.jpg">
<meta name="twitter:card" content="summary_large_image">
<meta property="og:site_name" content="The Digital Fix">
<meta property="og:type" content="website">
<meta property="og:description" content="During CinemaCon fans saw the first look at David Harbour&#039;s new action movie, Violent Night, which the star directly compared to the holiday classic - Die Hard ">
<meta property="og:title" content="David Harbour&#8217;s new action movie compared to Die Hard">
<meta property="og:url" content="https://www.thedigitalfix.com/violent-night/david-harbour-new-action-movie-die-hard">
<meta property="og:image" content="https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard.jpg">
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="robots" content="max-image-preview:large">
<script>var site = {"ajax_url":"https:\/\/www.thedigitalfix.com\/wp-admin\/admin-ajax.php"};</script>
<style>html>body{padding-top:var(--navbarHeight,60px)}@media screen and (min-width:900px){header.banner{position:fixed!important;top:0}html>body{padding-top:var(--navbarHeight,60px)}.bfa-loaded #nn_astro_wrapper{min-height:0;height:0}body.bfa-loaded{margin-top:0!important}#nn_astro_wrapper{height:250px;vertical-align:middle;text-align:center;position:relative;background:#fff;width:970px;margin:0 auto}#nn_astro_wrapper #nn_lb1{transform:translate(-50%,-50%);top:50%;left:50%;position:absolute}#nn_astro_wrapper #nn_lb1.lb-sticky{transform:none;top:60px;position:absolute;position:fixed;z-index:1000;left:calc(50% - 485px)}#nn_skin,#nn_skinl,#nn_skinr{position:fixed!important;top:0!important;padding-top:var(--navbarHeight,60px)!important}}.bfa-loaded #wpadminbar,.bfa-loaded.bfa-mini #wpadminbar{z-index:9999999999}body:not(.celtra-loaded):not(.bfa-loaded):not(.bfa-sticky-leaderboard) .celtra-reveal-header-sticky.banner{position:fixed!important}</style>
<script>window.AdSlots = { cmd: [], disableScripts: ['gpt','bk'], renderOnFirstLoad: false, divCheck: false }</script>
<script async src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src="https://kumo.network-n.com/dist/app.js" site="the-digital-fix"></script>
<script type="text/javascript">var narrativid = 'thedigitalfix';var amazon_ukid = 'digital.fix-21';var amazon_usid = 'digital.fix-20';var affiliate_windowid = '616453';var skimlinksid = '97464X1651631';var disclaimertext='Network N earns commission from qualifying purchases via Amazon Associates and other programs.';var constellation_key='0bd024c20270d6ceaebf6dedf2abcdae';var constellation_site='thedigitalfix';var affiliatedisclaimer = false;var new_affiliates_defaultRegion = 'USD';var new_affiliates_defaultCurrency = '$';var new_affiliates_maxEmbeds = 3;var possibleInvalidNetworkIds = new Array('30372','51552','dvdtimes01','thedigitalfix-21','thedvdforums-21','thedvdforums01','thedvdforums-20','616453','pcgamesn0f-21','pcgamesn-20','97464X1552553','digital.fix-21'); </script> <script type="text/javascript">
		(function(window, document, account) {
			window.skimlinks_exclude = ["shop-links.co", "shop-edits.co"];
			window.NRTV_EVENT_DATA = { donotlink: true };
			var b = document.createElement("script");
			b.type = "text/javascript";
			b.src = "https://static.narrativ.com/tags/" + account + ".js";
			b.async = true;
			var a = document.getElementsByTagName("script")[0];
			a.parentNode.insertBefore(b,a);
		})(window, document, narrativid);
	</script>
<style>body #site_wrap .post_footer .BeOpVSlot, body .next_page_placeholder .post_footer .BeOpVSlot{display:inline} body #site_wrap .post_footer .BeOpWidget+div, body #site_wrap .post_footer .BeOpWidget+p, body .next_page_placeholder .post_footer .BeOpWidget+div,  body .next_page_placeholder .post_footer .BeOpWidget+p{margin-top:35px}</style>
<script id="schema-plugin" data-page-type="post" type="application/ld+json">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</script>

<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0" />
<meta name="parsely-title" content="David Harbour&#8217;s new action movie compared to Die Hard" />
<meta name="parsely-link" content="https://www.thedigitalfix.com/violent-night/david-harbour-new-action-movie-die-hard" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-150x150.jpg" />
<meta name="parsely-pub-date" content="2022-04-28T10:48:03Z" />
<meta name="parsely-section" content="Violent Night" />
<meta name="parsely-author" content="Emma-Jane Betts" />
<meta name="parsely-tags" content="News-Cell" />

<script>
    window.addEventListener('NextPageInView', preventNullNextPages);

    function preventNullNextPages (eventData) {
      let finalElNum = window.InfiniteScroll.pageHistory[window.InfiniteScroll.pageHistory.length - 1].$el.dataset.pageId;
      let previousElNum = window.InfiniteScroll.pageHistory[window.InfiniteScroll.pageHistory.length - 2].$el.dataset.pageId;

      if (
        (finalElNum && previousElNum) &&
        (previousElNum >= finalElNum)
      ) {
        document.getElementsByClassName('js-ifs-nextpage')[0].remove();

        window.InfiniteScroll.homeFlowCounter = finalElNum;
        window.InfiniteScroll.currentOrderIndex = finalElNum;
        window.InfiniteScroll.currentPageIndex = finalElNum;
        window.InfiniteScroll.pageCounter = finalElNum;
      }
    }
  </script>
<link rel="preconnect" href="https://use.typekit.net"><style>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</style>
<link rel="preload" as="image" href="/wp-content/themes/thedigitalfix/dist/images/thedigitalfix.svg" />
<link rel="preload" as="image" href="/wp-content/themes/thedigitalfix/dist/images/search_icon.svg" />
<link rel="preload" as="image" href="https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard.jpg" imagesrcset="https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-740x416.jpg 740w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-768x432.jpg 768w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-900x506.jpg 900w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-580x326.jpg 580w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-297x167.jpg 297w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-183x103.jpg 183w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-280x158.jpg 280w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-263x148.jpg 263w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-213x120.jpg 213w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-233x132.jpg 233w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-860x485.jpg 860w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-175x99.jpg 175w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-330x185.jpg 330w" imagesizes="(max-width: 900px) 100vw, 900px" />
<link rel="apple-touch-icon" href="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/android-icon-48x48.png">
<link rel="shortcut icon" href="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/favicon.ico"> <link rel="alternate" type="application/rss+xml" title="The Digital Fix" href="/mainrss.xml" />
<meta property="fb:pages" content="337635522287" /> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-5484062-23"></script>
<script>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());



    gtag('config', 'UA-5484062-23', {
    'custom_map': {
        'dimension1': 'bluekai_id',
        'dimension3': 'content_id',
        'dimension4': 'section',
        'dimension8': 'pagetype',
        'dimension12': 'associatedip',
        'dimension15': 'featuredimage',
        'dimension16': 'thumbnail'
    },
    'content_id': '28830',
    'section': 'movies',
    'pagetype': 'article',
    'associatedip': 'violent-night',
    'featuredimage': 'https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard.jpg',
    'thumbnail': 'https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-330x185.jpg'
  });


__bluekai_data_sent = false;
function receiveMessage(event) {
  if (event.origin === 'http://tags.bluekai.com' || event.origin === 'https://stags.bluekai.com') {
    if (__bluekai_data_sent === false && typeof event.data !== 'undefined' && event.data.source === 'bluekai') {
      gtag('event', 'bluekai_id_dimension', {'bluekai_id': event.data.bluekaiId});
      __bluekai_data_sent = true;
    }
  }
}

addEventListener('message', receiveMessage, false);


</script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-TRRTR8K');</script>

</head>
<body class="post-template-default single single-post postid-28830 single-format-standard wp-featherlight-captions david-harbour-new-action-movie-die-hard tdf-default-template">
<script>
  window.beOpAsyncInit = function() {
    BeOpSDK.init({
      account: "60afb059b5e58a6db0d995c2",
      refreshExistingSlots: false
    });
    BeOpSDK.watch();
  };
</script>
<script async src="https://widget.beop.io/sdk.js"></script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TRRTR8K"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<header class="banner">
<div class="container" data-nosnippet>
<div><a class="brand" href="https://www.thedigitalfix.com/">The Digital Fix</a></div> <nav class="nav-primary">
<div id="menu_toggle"><input type="checkbox" /><span class="hamburger"></span><div class="menu-primary_navigation-container"><ul id="menu-primary_navigation" class="nav"><li class="menu-item"><a href="/tv">TV</a></li>
<li class="menu-item"><a href="/movies">Movies</a></li>
<li class="menu-item"><a href="/tech">Tech</a></li>
<li class="menu-item"><a href="https://forums.thedigitalfix.com/">Forum</a></li>
<li class="menu-header-community all-exclude menu-item menu-item-has-children main-dropdown"><a>Community</a>
<ul class="sub-menu">
<li class="community__twitter menu-item"><a href="https://twitter.com/thedigitalfix">Twitter</a></li>
<li class="community__facebook menu-item"><a href="https://www.facebook.com/thedigitalfix/">Facebook</a></li>
<li class="community__instagram menu-item"><a href="https://www.instagram.com/thedigitalfix/">Instagram</a></li>
</ul>
</li>
<li class="all-exclude menu-item menu-item-has-children main-dropdown"><a>More</a>
<ul class="sub-menu">
<li class="menu-item"><a href="https://www.thedigitalfix.com/about-us">About Us</a></li>
<li class="menu-item"><a href="/archives/">Archive</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/pitch-to-us">Pitch to Us</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/careers">Careers</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/terms-conditions">Terms &#038; Conditions</a></li>
<li class="nn-cmp-show menu-item"><a href="/privacy-policy">Cookie Policy</a></li>
</ul>
</li>
<li class="mobile-footer"><a href="">A <img src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/NetworkN_white.svg">Brand</a></li></ul></div></div> </nav>
<nav class="nav-secondary">
<a href="https://www.thedigitalfix.com/search" class="header-search"></a>
<a href="https://www.network-n.com" target="_blank" rel="noopener" class="network-logo">Network-N</a>
</nav>
<div id="header-searchbox"><form method="get" action="https://www.thedigitalfix.com/" id="header-search-form"><input id="header-search-input" name="s" id="term" /></form></div>
<div id="header-search-suggestions"></div>
</div>
</header>
<div id="nn_astro_wrapper"><div class="nn_bb ad" id="nn_lb1"></div></div><div class="ad" id="nn_lb2"></div><div class="ad" id="nn_mobile_lb1"></div><div id="site_wrap" class="" role="document">
<article class="post-28830 post type-post status-publish format-standard has-post-thumbnail hentry category-violent-night">
<header class="article-header">
<div id="article-details">
<h1 class="entry-title">David Harbour&#8217;s new action movie compared to Die Hard</h1>
<div class="fader"></div>
</div>
<div class="article-featured-image"><img width="900" height="506" src="https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-900x506.jpg" class="webfeedsFeaturedVisual type:primaryImage wp-post-image" alt="David Harbour&#039;s new action movie compare to Die Hard" title="David Harbour&#8217;s new action movie compared to Die Hard" srcset="https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-900x506.jpg 900w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-740x416.jpg 740w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-768x432.jpg 768w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-580x326.jpg 580w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-297x167.jpg 297w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-183x103.jpg 183w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-280x158.jpg 280w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-263x148.jpg 263w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-213x120.jpg 213w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-233x132.jpg 233w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-860x485.jpg 860w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-175x99.jpg 175w, https://www.thedigitalfix.com/wp-content/uploads/2022/04/david-harbour-new-action-movie-compared-to-die-hard-330x185.jpg 330w" sizes="(max-width: 900px) 100vw, 900px"></div> </header>
<div class="entry-content">
<p class="intro_text">CinemaCon is the gift that keeps on giving, as a surprising thriller movie that was on no one&rsquo;s radar has suddenly grabbed every adrenaline enthusiast&rsquo;s attention. Violent Night, an <a href="https://www.thedigitalfix.com/best-action-movies" rel="noopener">action movie</a> starring David Harbour&nbsp;of&nbsp;<a href="https://www.thedigitalfix.com/stranger-things" rel="noopener">Stranger Things</a> fame, was introduced and may just be, according to Harbour, the next <a href="https://www.thedigitalfix.com/die-hard" rel="noopener">Die Hard</a>.</p>
<p>Directed by Tommy Wirkola (Dead Snow), Violent Night follows a family who is kidnapped by mercenaries on Christmas Eve &ndash; causing Santa Claus (Harbour) to come to their rescue. The upcoming film also stars the likes of John Leguizamo, Beverly D&rsquo;Angelo, Alex Hassell, and Edi Patterson. During the Universal Pictures panel at CinemaCon (via <a href="https://comicbook.com/movies/news/violent-night-david-harbour-santa-claus-thriller-die-hard/" rel="noopener">Comicbook.com</a>), Harbour enthusiastically introduced the film, comparing the upcoming flick to the hit 1988 movie starring Bruce Willis &ndash; Die Hard.</p>
<p>&ldquo;Escape is great. I&rsquo;m a big fan. But what about movies that make you sweat?&rdquo; Harbour said. &ldquo;Don&rsquo;t you love action movies? Who doesn&rsquo;t love a great action movie, right? How about Christmas movies? So, what about a movie that&rsquo;s a great action movie, and the greatest Christmas movie in one? Die Hard. Fucking Die Hard.&rdquo;</p>
<div class="legion_primiswrapper"><div id="nn_player"></div></div>
<p>&ldquo;Now what if&hellip;wait a minute, wait a minute. What if kick-ass director Tommy Wirkola and the badass producers at 87North, you know, the maniacs who did Atomic Blonde and John Wick and Nobody and Hobbs and Shaw, were behind it all?&rdquo; He continued. &ldquo;And, wait a minute, what if I started in it as fucking Santa Claus? Oh, do I swing a mother fucking hammer?&rdquo;</p>
<div class="new_affiliate_embed" contenteditable="false" data-usd-type="pricecomparison" data-gbp-type="pricecomparison" data-usd-ean="0024543348078" data-usd-title="Die Hard 5-Movie Collection [Blu-ray]" data-usd-image="https://m.media-amazon.com/images/I/61T7-RjF4mL._SL500_.jpg" data-gbp-ean="5039036061056" data-gbp-title="Die Hard - Legacy Collection (Films 1-5) [Blu-ray] [1988]" data-gbp-image="https://m.media-amazon.com/images/I/51Xlugrl+AL._SL500_.jpg"></div>
<p>&ldquo;Yes. What you&rsquo;re about to see is not an actual trailer, I don&rsquo;t think, but you better not cry to somebodyy,&rdquo; he says. &ldquo;You better not pout. I&rsquo;m telling you why. Because Santa Claus is coming to town. Let&rsquo;s fucking go.&rdquo;</p>
<p>In the <a href="https://www.thedigitalfix.com/best-80s-movies" rel="noopener">80s movie</a> Die Hard, police officer John McClane tries to save his wife after German terrorists take her hostage during a Christmas party. Although Willis isn&rsquo;t Santa Claus in the film, the rescue storyline feels familiar to Violent Night&rsquo;s plot synopsis.</p>
<p>From Harbour&rsquo;s words, it appears that Violent Night is gunning for the same <a href="https://www.thedigitalfix.com/best-christmas-movies" rel="noopener">Christmas movie</a> acclaim as McClane&rsquo;s debut feature. However, only time will tell if it can cement its place as a holiday classic too.</p>
<div class="left-column">
<section id="author-and-social">
<img alt="" class="avatar avatar-80 photo avatar-default lazyload" height="80" width="80" data-src="https://www.thedigitalfix.com/wp-content/uploads/2021/06/Emma.jpg"> <a class="author-name" href="https://www.thedigitalfix.com/author/emma-jane-betts" rel="noopener">Emma-Jane Betts</a>
<p class="job-title">Staff Writer</p>
<p class="updated-date">Updated: Apr 28, 2022</p>
<p class="social-call"><b>Follow us</b></p>
<hr>
<p class="social-icons"><a class="meta-icon" target="_blank" href="https://www.facebook.com/thedigitalfix/" rel="noopener"><img width="20" height="20" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/icons/fb_white.svg"></a><a class="meta-icon" target="_blank" href="https://twitter.com/thedigitalfix" rel="noopener"><img width="20" height="20" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/icons/tw_white.svg"></a><a class="meta-icon" target="_blank" href="https://www.instagram.com/thedigitalfix" rel="noopener"><img width="20" height="20" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/icons/ig_white.svg"></a><a class="meta-icon" target="_blank" href="https://www.youtube.com/channel/UCelDv5XCqbEQbGT_MvsJ_Ug" rel="noopener"><img width="20" height="20" class="lazyload" data-src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/icons/yt_white.svg"></a></p>
</section>
<section id="taxonomy">
<b class="category_title"><a href="https://www.thedigitalfix.com/violent-night" rel="noopener">Violent Night</a></b>
<div class="category_facets">
<a href="https://www.thedigitalfix.com/genre/action-and-adventure" rel="noopener">Action &amp; adventure</a>
<a href="https://www.thedigitalfix.com/genre/thriller" rel="noopener">Thriller</a>
<a href="https://www.thedigitalfix.com/other/movies" rel="noopener">Movies</a>
</div>
</section>
<section id="get-involved">
<b>Get involved</b>
<hr>
Continue the conversation over on
<a href="https://forums.thedigitalfix.com/forums/" rel="noopener">The Digital Fix Forum</a>
</section>
</div>
</div>
</article>
<div class="post_footer">
<p class="social_cta">
Be part of the conversation by heading over to our <a href="https://www.facebook.com/thedigitalfix/">Facebook page</a>. To stay up to date with all the latest entertainment news, guides, opinion, and reviews, follow The Digital Fix on <a href="https://twitter.com/thedigitalfix">Twitter</a>.<br />
<br />
We sometimes include relevant affiliate links in articles from which we earn a small commission. Any stated prices are correct at the time of publication. For more information, click <a href="https://www.thedigitalfix.com/terms-and-conditions">here</a>. </p>
<div class="BeOpWidget" data-name="below-article"></div><div class="hidden_meta">{"schema":{"page":{"content":{"headline":"David Harbour&#8217;s new action movie compared to Die Hard","type":"news","category":"violent-night"},"user":{"loginstatus":false},"game":{"publisher":"","genre":"Action & adventure","title":"Violent Night","genres":["Action & adventure","Thriller","Movies"]}}}}</div><div class="disclaimer">
We sometimes include relevant affiliate links in articles from which we earn a small commission.
For more information, <a href="/terms-and-conditions">click here</a>.
</div> </div>
<script src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/js/posts.f8c04b2e.min.js"></script><div class="OUTBRAIN" data-src="https://www.thedigitalfix.com/violent-night/david-harbour-new-action-movie-die-hard" data-widget-id="AR_1"></div> <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script><script>window.addEventListener("NextPageInView", function(e) { console.log("Outbrain Refresh"); OBR.extern.researchWidget(); });</script>
</div>
<div id="sidebar-background"></div>
<section id="sidebar"><span class="sidebar-heading">Trending in <b>Movies</b></span>
<a href="/american-horror-story/season-11-release-date">
<article class="sidebar-preview trending">
<div class="thumbnail"><img src="https://www.thedigitalfix.com/wp-content/uploads/2022/04/american-horror-story-season-11-release-date-header-330x185.jpg" alt=""></div>
<span class="title"><span>1</span>American Horror Story season 11 release date, plot, trailer, and more </span>
</article>
</a>
<a href="/oscars/chris-rock-addresses-will-smith-slap">
<article class="sidebar-preview trending">
<span class="title"><span>2</span>Chris Rock addresses Will Smith slap during stand up set </span>
</article>
</a>
<a href="/oscars/terry-crews-shares-his-thoughts-on-will-smith-slap">
<article class="sidebar-preview trending">
<span class="title"><span>3</span>Terry Crews shares his thoughts on Will Smith slap </span>
</article>
</a>
<div class="sticky_rail600 inlinerail"><div class="nn_inline_mp ad" id="nn_mpu1"></div></div>
<span class="sidebar-heading">Latest in <b>Movies</b></span>
<a href="/david-harbours-new-action-movie-compared-to-die-hard">
<article class="sidebar-preview latest">
<span class="title">David Harbour's new action movie compared to Die Hard</span>
</article>
</a>
<a href="/jordan-peele-explains-meaning-behind-the-title-nope">
<article class="sidebar-preview latest">
<span class="title">Jordan Peele explains meaning behind the title Nope</span>
</article>
</a>
<a href="/halloween-ends-release-date-cast-trailer-and-more">
<article class="sidebar-preview latest">
<span class="title">Halloween Ends: release date, cast, trailer and more</span>
</article>
</a>
<a href="/fans-react-to-halloween-ends-cinemacon-footage">
<article class="sidebar-preview latest">
<span class="title">Fans react to Halloween Ends CinemaCon footage</span>
</article>
</a>
<a href="/denzel-washingtons-equalizer-3-gets-release-date">
<article class="sidebar-preview latest">
<span class="title">The Equalizer 3 - what will happen in the new Denzel Washington movie?</span>
</article>
</a>
<div class="sticky_rail600"><div class="ad" id="nn_mpu2"></div></div>
<section class="sidebar-footer">
A <img class="brand" src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/NetworkN_white.svg"> brand
</section>
</section>
<footer class="site-footer">
<div class="container">
<div class="footer-brand">
<span class="footer-copyright">&copy; 2022</span>
<span class="brand-networkn">Powered by Network-N</span>
</div>
<ul class="footer-links">
<li><a href="https://www.thedigitalfix.com/terms-and-conditions">Terms and conditions</a>
<li><a href="https://www.thedigitalfix.com/about-us">About us</a>
<li><a href="https://www.thedigitalfix.com/careers">Careers</a>
</ul>
</div>
</footer>
<script>
    var constellation_deals_formats = 'Headphones|Home Cinema & Entertainment Tech|DVD & Blu-Ray|DVD|TVs';
    var constellation_deals_rows = '10';
    var constellation_deals_mindiscount = '1';
    </script>
<script src="https://constellation.network-n.com/shared/constellation-deals.js?cacheflag=10"></script>
<link rel="stylesheet" href="https://constellation.network-n.com/shared/constellation-deals.css?cacheflag=10" />
<div class="nn_skinl ad" id="nn_skinl"></div><div class="nn_skinr ad" id="nn_skinr"></div><div class="js-ifs-nextpage articles_container">
<div class="loading"><div class="loading-text"></div>
<svg class="spinner" viewBox="0 0 50 50"><circle class="path" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg>
</div>
</div>

<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="thedigitalfix.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<script>window.disableFlowAds = true;</script> <script type="text/javascript">
    var main_css = document.createElement('link');
    main_css.rel = 'stylesheet';
    main_css.href = 'https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/styles/main.f8c04b2e.css';
    main_css.type = 'text/css';
    let linkTags = document.getElementsByTagName('link');
    var main_css_target = linkTags[(linkTags.length)];
    var main_css_target = document.getElementsByTagName('link')[0];
    main_css_target.parentNode.insertBefore(main_css, main_css_target);
    </script>
<style>
        #nn_skinr,
        #nn_skinl {            
            left: 50%;
            margin-top: 20px;
            margin-left: -970px!important;
            z-index: 100;
            padding-top: 80px;
        }
        #nn_skinr {
            margin-left: 650px!important;
        }
        #nn_skinl {
            width: 300px;
            text-align: right;  
        }
        
    </style>
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-advertising-atlasastro/dist/css/app.74b8e612.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/patch-notes/patch-notes.css?cb_20220428">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/post-types.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/jquery-ui.min.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/nn-images.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/featherlight/featherlight.gallery.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/featherlight-overrides.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/css/wp-featherlight.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/gallery.css">
<script type='text/javascript'>
/* <![CDATA[ */
var teadsConfig = {"page":"","placement":""};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-advertising-atlasastro/dist/js/app.74b8e612.min.js"></script>
<script src="https://www.thedigitalfix.com/wp-includes/js/jquery/jquery.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-includes/js/jquery/jquery-migrate.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/patch-notes/patch-notes.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/post-types.js?nc140420"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-includes/js/jquery/ui/core.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/jquery-ui.min.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var legion_games = {"ajax_url":"https:\/\/www.thedigitalfix.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/legion-games.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/mce-table-buttons/mobile_tables.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ifs_data = {"target_container":".js-ifs-nextpage","ordering":{"home":["home-normal"],"game":["game-normal"],"article":["19114","600","16626","14687","16413","article-specified","game-normal"]},"flow_type":"article","author_name":"","pid":"28830","paged":"2","homepage":"","search_keyword":"","gametype":"","month":"0","year":"0","ignore_post_ids":[]};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/new-infinite-scroll/dist/js/app.71bbd3d3.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/nn-images.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-pagespeed/js/lazysizes.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/jquery.detect_swipe.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/featherlight.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/featherlight.gallery.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/wpFeatherlight.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/main-356d78ed96.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/custom-6ecfacf2bc.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/mobile-fbad030ed9.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/feature-video-8e2531fa9c.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/video-759f4d116e.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/./js/main.f8c04b2e.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/hammer.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/gallery.js"></script>
</body>
</html>
