<!doctype html>
<html lang="en-GB">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="preload" as="image" href="/wp-content/themes/thedigitalfix/dist/images/thedigitalfix.svg" />
<link rel="preload" as="image" href="/wp-content/themes/thedigitalfix/dist/images/search_icon.svg" />
<link rel="preload" as="image" href="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1-550x309.jpeg" />
<title>Just Beyond season 2 release date speculation, plot, cast, and more | The Digital Fix</title>
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-permutive/assets/style.css"><script src="https://www.thedigitalfix.com/wp-content/plugins/legion-permutive/assets/app.js"></script><script defer src="https://www.thedigitalfix.com/wp-content/plugins/legion-single-action-widget/public/js/legion-single-action-widget-public.js?cachebust=2"></script><link rel="preconnect" href="https://cdn.consentmanager.mgr.consensu.org/" crossorigin>
<link rel="preconnect" href="https://mb.moatads.com">
<link rel="preconnect" href="https://securepubads.g.doubleclick.net/" crossorigin>
<link rel="preconnect" href="https://c.amazon-adsystem.com/" crossorigin>
<link rel="preconnect" href="https://kumo.network-n.com/dist/app.js" crossorigin>
<link rel="preconnect" href="https://constellationv2.network-n.com" crossorigin> <link rel="canonical" href="https://www.thedigitalfix.com/disney-plus/just-beyond-season-2-release-date">
<meta name="description" content="The anthology horror series was a hit when it dropped in October 2021, here&#039;s what we know about a potential Just Beyond season 2 release date">
<meta name="twitter:image" content="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1.jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta property="og:site_name" content="The Digital Fix">
<meta property="og:type" content="website">
<meta property="og:description" content="The anthology horror series was a hit when it dropped in October 2021, here&#039;s what we know about a potential Just Beyond season 2 release date">
<meta property="og:title" content="Just Beyond season 2 release date speculation, plot, cast, and more">
<meta property="og:url" content="https://www.thedigitalfix.com/disney-plus/just-beyond-season-2-release-date">
<meta property="og:image" content="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1.jpeg">
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="robots" content="max-image-preview:large">
<script>var site = {"ajax_url":"https:\/\/www.thedigitalfix.com\/wp-admin\/admin-ajax.php"};</script>
<style>html>body{padding-top:var(--navbarHeight,60px)}@media screen and (min-width:900px){header.banner{position:fixed!important;top:0}html>body{padding-top:var(--navbarHeight,60px)}.bfa-loaded #nn_astro_wrapper{min-height:0;height:0}body.bfa-loaded{margin-top:0!important}#nn_astro_wrapper{height:250px;vertical-align:middle;text-align:center;position:relative;background:#fff;width:970px;margin:0 auto}#nn_astro_wrapper #nn_lb1{transform:translate(-50%,-50%);top:50%;left:50%;position:absolute}#nn_astro_wrapper #nn_lb1.lb-sticky{transform:none;top:60px;position:absolute;position:fixed;z-index:1000;left:calc(50% - 485px)}#nn_skin,#nn_skinl,#nn_skinr{position:fixed!important;top:0!important;padding-top:var(--navbarHeight,60px)!important}}.bfa-loaded #wpadminbar,.bfa-loaded.bfa-mini #wpadminbar{z-index:9999999999}body:not(.celtra-loaded):not(.bfa-loaded):not(.bfa-sticky-leaderboard) .celtra-reveal-header-sticky.banner{position:fixed!important}</style>
<script>window.AdSlots = { cmd: [], disableScripts: ['gpt','bk'], renderOnFirstLoad: false, divCheck: false }</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src="https://kumo.network-n.com/dist/app.js" site="the-digital-fix"></script>
<script type="text/javascript">var narrativid = 'thedigitalfix';var amazon_ukid = 'digital.fix-21';var amazon_usid = 'digital.fix-20';var affiliate_windowid = '616453';var skimlinksid = '97464X1651631';var disclaimertext='Network N Media earns commission from qualifying purchases via Amazon Associates and other programs. We include affiliate links in articles. <a href=/terms-and-conditions>View terms</a>. Prices correct at time of publication. ';var constellation_key='0bd024c20270d6ceaebf6dedf2abcdae';var constellation_site='thedigitalfix';var constellation_url='https://constellationv2.network-n.com';var affiliatedisclaimer = false;var new_affiliates_defaultRegion = 'USD';var new_affiliates_defaultCurrency = '$';var new_affiliates_maxEmbeds = 3;var possibleInvalidNetworkIds = new Array('30372','51552','dvdtimes01','thedigitalfix-21','thedvdforums-21','thedvdforums01','thedvdforums-20','616453','pcgamesn0f-21','pcgamesn-20','97464X1552553','digital.fix-21'); </script> <script type="text/javascript">
		(function(window, document, account) {
			window.skimlinks_exclude = ["shop-links.co", "shop-edits.co"];
			window.NRTV_EVENT_DATA = { donotlink: true };
			var b = document.createElement("script");
			b.type = "text/javascript";
			b.src = "https://static.narrativ.com/tags/" + account + ".js";
			b.async = true;
			var a = document.getElementsByTagName("script")[0];
			a.parentNode.insertBefore(b,a);
		})(window, document, narrativid);
	</script>
<style>body #site_wrap .post_footer .BeOpVSlot, body .next_page_placeholder .post_footer .BeOpVSlot{display:inline} body #site_wrap .post_footer .BeOpWidget+div, body #site_wrap .post_footer .BeOpWidget+p, body .next_page_placeholder .post_footer .BeOpWidget+div,  body .next_page_placeholder .post_footer .BeOpWidget+p{margin-top:35px}</style>
<script id="schema-plugin" data-page-type="post" type="application/ld+json">{"@context":"https://schema.org","@graph":[{"@type":"NewsArticle","author":{"@type":"Person","@id":"https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/01/v2-charlotte-digital-fix.jpg","name":"Charlotte Colombo","image":{"@type":"ImageObject","@id":"https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/01/v2-charlotte-digital-fix.jpg#image","inLanguage":"en","url":"https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/01/v2-charlotte-digital-fix.jpg","contentUrl":"https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/01/v2-charlotte-digital-fix.jpg","caption":"Charlotte Colombo"},"description":"Chronically online. Official Staff Writer and unofficial TikTok, <a href=\"https://www.thedigitalfix.com/the-boys\">The Boys</a>, <a href=\"https://www.thedigitalfix.com/marvel-cinematic-universe/\">MCU</a>, and <a href=\"https://www.thedigitalfix.com/best-streaming-services\">streaming service</a> expert. Past bylines include Business Insider, VICE, Rolling Stone, NBC, The Independent and more.","sameAs":["https://twitter.com/colombochar"],"url":"https://www.thedigitalfix.com/author/charlotte-colombo"},"headline":"Just Beyond season 2 release date speculation, plot, cast, and more","datePublished":"2022-10-19T16:19:50+00:00","dateModified":"2022-10-19T16:19:50+00:00","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.thedigitalfix.com/disney-plus/just-beyond-season-2-release-date"},"wordCount":626,"publisher":{"@type":"Organization","@id":"https://www.thedigitalfix.com/#organization","name":"The Digital Fix","url":"https://www.thedigitalfix.com","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.thedigitalfix.com/#logo","inLanguage":"en","url":"https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/apple-touch-icon.png","contentUrl":"https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/apple-touch-icon.png","width":192,"height":192,"caption":"The Digital Fix logo"},"image":"https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/apple-touch-icon.png"},"image":{"@type":"ImageObject","@id":"https://www.thedigitalfix.com/disney-plus/just-beyond-season-2-release-date#primaryimage","inLanguage":"en","url":"https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1.jpeg","contentUrl":"https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1.jpeg","width":1920,"height":1080,"caption":"Just Beyond season 2 release date speculation, plot, cast, and more"},"thumbnailUrl":"https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1.jpeg","articleSection":["Disney Plus","Disney Plus"],"dateline":"Wednesday, October 19th, 2022","isAccessibleForFree":"True","video":{"@type":"VideoObject","@id":"https://www.thedigitalfix.com/disney-plus/just-beyond-season-2-release-date/#video","name":"Just Beyond season 2 release date speculation, plot, cast, and more","isPartOf":{"@id":"https://www.thedigitalfix.com/disney-plus/just-beyond-season-2-release-date"},"thumbnailUrl":"https://img.youtube.com/vi/L2GVrR8233E\r/sddefault.jpg","width":480,"height":270,"embedUrl":"https://www.youtube.com/embed/L2GVrR8233E\r","inLanguage":"en-US","uploadDate":"2022-10-19T16:19:50+00:00","description":"The anthology horror series was a hit when it dropped in October 2021, here's what we know about a potential Just Beyond season 2 release date"}},{"@type":"BreadcrumbList","itemListElement":[{"@context":"https://schema.org","@type":"ListItem","position":1,"item":{"@id":"https://www.thedigitalfix.com/","name":"Home"}},{"@context":"https://schema.org","@type":"ListItem","position":2,"item":{"@id":"https://www.thedigitalfix.com/disney-plus","name":"Disney Plus"}},{"@context":"https://schema.org","@type":"ListItem","position":3,"item":{"@id":"https://www.thedigitalfix.com/disney-plus/just-beyond-season-2-release-date","name":"Just Beyond season 2 release date speculation, plot, cast, and more"}}]}]}</script>

<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0" />
<meta name="parsely-title" content="Just Beyond season 2 release date speculation, plot, cast, and more" />
<meta name="parsely-link" content="https://www.thedigitalfix.com/disney-plus/just-beyond-season-2-release-date" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1-150x150.jpeg" />
<meta name="parsely-pub-date" content="2022-10-19T16:19:50Z" />
<meta name="parsely-section" content="Disney Plus" />
<meta name="parsely-author" content="Charlotte Colombo" />
<meta name="parsely-tags" content="Guide-Cell" />

<script>
    window.addEventListener('NextPageInView', preventNullNextPages);

    function preventNullNextPages (eventData) {
      let finalElNum = window.InfiniteScroll.pageHistory[window.InfiniteScroll.pageHistory.length - 1].$el.dataset.pageId;
      let previousElNum = window.InfiniteScroll.pageHistory[window.InfiniteScroll.pageHistory.length - 2].$el.dataset.pageId;

      if (
        (finalElNum && previousElNum) &&
        (previousElNum >= finalElNum)
      ) {
        document.getElementsByClassName('js-ifs-nextpage')[0].remove();

        window.InfiniteScroll.homeFlowCounter = finalElNum;
        window.InfiniteScroll.currentOrderIndex = finalElNum;
        window.InfiniteScroll.currentPageIndex = finalElNum;
        window.InfiniteScroll.pageCounter = finalElNum;
      }
    }
  </script>
<style>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</style>
<link rel="apple-touch-icon" href="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/apple-touch-icon.png">
<link rel="shortcut icon" href="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/images/favicon/favicon.ico?26112020"> <link rel="alternate" type="application/rss+xml" title="The Digital Fix" href="https://www.thedigitalfix.com/mainrss.xml" />
<meta property="fb:pages" content="337635522287" /> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-5484062-23"></script>
<script>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());



    gtag('config', 'UA-5484062-23', {
    'custom_map': {
        'dimension3': 'content_id',
        'dimension4': 'section',
        'dimension8': 'pagetype',
        'dimension12': 'associatedip',
        'dimension15': 'featuredimage',
        'dimension16': 'thumbnail'
    },
    'content_id': '47383',
    'section': 'tv',
    'pagetype': 'article',
    'associatedip': 'disney-plus',
    'featuredimage': 'https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1.jpeg',
    'thumbnail': 'https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1-330x185.jpeg'
  });

    
    gtag('config', 'G-RE7LVHSPP4', {
        'custom_map': {
            'dimension3': 'content_id',
            'dimension4': 'section',
            'dimension8': 'pagetype',
            'dimension12': 'associatedip',
            'dimension15': 'featuredimage',
            'dimension16': 'thumbnail'
        },
        'content_id': '47383',
        'section': 'tv',
        'pagetype': 'article',
        'associatedip': 'disney-plus',
        'featuredimage': 'https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1.jpeg',
        'thumbnail': 'https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1-330x185.jpeg'
    });

  
  
</script>
</head>
<body class="guide-template-default single single-guide postid-47383 wp-featherlight-captions just-beyond-season-2-release-date has-sidebar tdf-default-template">
<script>
  window.beOpAsyncInit = function() {
    BeOpSDK.init({
      account: "60afb059b5e58a6db0d995c2",
      refreshExistingSlots: false
    });
    BeOpSDK.watch();
  };
</script>
<script async src="https://widget.beop.io/sdk.js"></script>
<header class="banner">
<div class="container" data-nosnippet>
<div><a class="brand" href="https://www.thedigitalfix.com/">The Digital Fix</a></div> <nav class="nav-primary">
<div id="menu_toggle"><input type="checkbox" /><span class="hamburger"></span><div class="menu-primary_navigation-container"><ul id="menu-primary_navigation" class="nav"><li class="menu-item"><a title="TV and Movie News" href="/news">News</a></li>
<li class="menu-item"><a title="Marvel Cinematic Universe News" href="/marvel-cinematic-universe">MCU</a></li>
<li class="menu-item"><a title="DC Comics Expanded Universe News" href="/dc-extended-universe">DCEU</a></li>
<li class="menu-item"><a title="Star Wars News" href="/star-wars">Star Wars</a></li>
<li class="menu-header-community all-exclude menu-item menu-item-has-children main-dropdown"><a>Community</a>
<ul class="sub-menu">
<li class="community__twitter menu-item"><a title="The Digital Fix Twitter" href="http://go.thedigitalfix.com/Twitter">Twitter</a></li>
<li class="community__facebook menu-item"><a title="The Digital Fix Facebook" href="http://go.thedigitalfix.com/Facebook">Facebook</a></li>
<li class="community__instagram menu-item"><a href="https://www.instagram.com/thedigitalfix/">Instagram</a></li>
</ul>
</li>
<li class="all-exclude menu-item menu-item-has-children main-dropdown"><a>More</a>
<ul class="sub-menu">
<li class="menu-item"><a href="https://www.thedigitalfix.com/about-us">About Us</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/pitch-to-us">Pitch to Us</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/careers">Careers</a></li>
<li class="menu-item"><a href="https://www.thedigitalfix.com/terms-conditions">Terms &#038; Conditions</a></li>
<li class="nn-cmp-show menu-item"><a href="/privacy-policy">Cookie Policy</a></li>
</ul>
</li>
</ul></div></div> </nav>
<nav class="nav-secondary">
<a href="https://www.thedigitalfix.com/search" class="header-search"></a>
<a href="https://www.network-n.com" target="_blank" rel="noopener" class="network-logo">Network-N</a>
</nav>
<div id="header-searchbox"><form method="get" action="https://www.thedigitalfix.com/" id="header-search-form"><input id="header-search-input" name="s" id="term" /></form></div>
<div id="header-search-suggestions"></div>
</div>
</header>
<div id="nn_astro_wrapper"><div class="nn_bb ad" id="nn_lb1"></div></div><div class="ad" id="nn_lb2"></div><div class="ad" id="nn_mobile_lb1"></div><div id="site_wrap" class="" role="document">
<article class="post-47383 guide type-guide status-publish has-post-thumbnail hentry category-disney-plus">
<header class="feature-header">
<div id="article-details">
<h1 class="entry-title">Just Beyond season 2 release date speculation, plot, cast, and more</h1>
<p class="caption">The anthology horror series was a hit when it dropped in October 2021, here's what we know about a potential Just Beyond season 2 release date</p> </div>
<div class="article-featured-image"><img width="550" height="309" src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1-550x309.jpeg" class="webfeedsFeaturedVisual type:primaryImage wp-post-image" alt="Just Beyond season 2 release date: Just Beyond season 1" srcset="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1-550x309.jpeg 550w, https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1-860x485.jpeg 580w" sizes="(min-width: 550px) 550px" title="Just Beyond season 2 release date speculation, plot, cast, and more"></div>
</header>
<div class="entry-meta">
<div class="author-avatar">
<img alt="" class="avatar avatar-50 photo avatar-default" height="50" src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/01/v2-charlotte-digital-fix.jpg" width="50"> </div>
<div class="entry-meta-details">
<p class="name-title">
<a class="link-author" href="https://www.thedigitalfix.com/author/charlotte-colombo" rel="author" target="_blank">
Charlotte Colombo </a>
</p>
<p class="entry-meta-pubdate no-roundel">
<span>Published: </span><time class="updated" datetime="2022-10-19T17:19:50+00:00">Oct 19, 2022 12:19 ET</time> </p>
</div>
<div class="game_list"><span class="category_title"><a href="https://www.thedigitalfix.com/disney-plus" target="_blank">Disney Plus</a></span></div> </div>
<div class="entry-content">
<p class="intro_text"><strong>What is the Just Beyond season 2 release date?&nbsp;</strong>When it comes to <a href="https://www.thedigitalfix.com/best-horror-series" rel="noopener">horror series</a>, not all of them&nbsp;are child-friendly, and that&rsquo;s what makes Just Beyond such a unique <a href="https://www.thedigitalfix.com/best-tv-series" rel="noopener">TV series</a>. Based on the graphic novels of the same name by R.L. Stine, Just Beyond is a horror <a href="https://www.thedigitalfix.com/best-comedy-series" rel="noopener">comedy series</a> with an anthology format, with each of the eight episodes focussing on an independent horror story.
</p><div class="legion_primiswrapper"><div id="nn_player"></div></div>
<p>Showrunner, Seth Grahame Smith, is most famous for novels such as Pride and Prejudice and Zombies, which was later adapted into a <a href="https://www.thedigitalfix.com/best-fantasy-movies" rel="noopener">fantasy movie</a>. For&nbsp;season 1 of Just Beyond,&nbsp;he was joined by a number of executive producers including Seth Grahame-Smith, David Katzenberg, Aaron Schmidt, David Walpert, Marc Webb, Stephen Christy, Ross Richie, and Robert Lawrence Stine.
</p><div class="nn_mobile_mpu_wrapper"></div>
<p>Back in October 2021, during a panel at New York Comic-Con, Smith said he was open to future Just Beyond seasons, saying, &ldquo;If Disney&nbsp;Plus wants another season, in my mind, there&rsquo;s like, five more seasons of stories that I want to tell with this, at least. But it&rsquo;s not my choice.&rdquo; Clearly, there are a lot of routes this Disney Plus series can go, so here&rsquo;s everything we know about a <strong>Just Beyond season 2 release date</strong>.
</p><h2>Just Beyond season 2 release date speculation</h2>
<p><strong>If we&rsquo;re being honest, it&rsquo;s looking more and more likely that Just Beyond isn&rsquo;t getting a season 2 at all.&nbsp;</strong>
</p><p>With season 1 being released over a year ago on September 2021, we feel like Disney Plus would&rsquo;ve mentioned by now if there was a season 2 in the works &mdash; it&rsquo;s common practise for the <a href="https://www.thedigitalfix.com/best-streaming-services" rel="noopener">streaming service</a> to do this for other original series within weeks of the first season dropping &mdash; and failing that, we just had Disney Plus Day 2022, which would&rsquo;ve been a prime opportunity to announce a Just Beyond season 2.
</p><p>That being said, neither cast members nor those behind the scenes have confirmed that the series has cancelled, meaning that the fate of Just Beyond season 2 may not be sealed after all. It could be the case that they&rsquo;re keeping an official season 2 announcement for a later date or, given their reputation as a spooky show, want to surprise fans with the unveiling.
</p><p>Either way, we know from season 1 that it takes 7 months from the start of production to the series dropping on-screen, so if we want to be optimistic for a September 2023 release date, we can keep our fingers crossed for news on production commencing as late as February 2023.
</p><div class="youtube" data-embed="L2GVrR8233E" data-embed-type="standard"><img src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/images/lazyload_placeholder.svg" alt="YouTube Thumbnail" width="100%" height="309" class="lazyload" data-src="https://img.youtube.com/vi/L2GVrR8233E/maxresdefault.jpg" loading="lazy">
<div class="play-button"></div>
</div>
<h2>Just Beyond season 2 plot speculation</h2>
<p>There&rsquo;s countless short stories from R.L. Stine&rsquo;s graphic novels that can be adapted into standalone stories, including The Scare School (where middle-schoolers find a monster wandering their school), The Horror at Happy Landings (where martians from outer-space take over the bodies of two children), Monstrosity (where monsters from classic horror movies come to life after a family buys a notorious Hollywood horror&nbsp;film studio), and many others.
</p><p>Furthermore, as some anthology series have done in the past, some episodes may well continue the stories first told in season 1.
</p><p><img class="aligncenter size-legion-featured-2022 wp-image-47483 lazyload" title="Just Beyond season 2 release date: Just Beyond season 1 cast" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/images/lazyload_placeholder.svg" alt="Just Beyond season 2 release date: Just Beyond season 1 cast" width="550" height="309" data-src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/Just-Beyond-season-2-release-date-Just-Beyond-season-1-cast-550x309.jpeg" loading="lazy">
</p><h2>Just Beyond season 2 cast speculation</h2>
<p>Because each episode of Just Beyond is a separate story, there is a different cast for each one. If a second season is commissioned, it remains to be seen whether like American Horror Story, a number of cast members will return playing different roles, or if we can expect an entirely new line-up. If they decide to go down the American Horror Story route, here&rsquo;s who we suspect might be among those returning:
</p><h4>Just Beyond season 2 cast speculation</h4>
<ul>
<li>McKenna Grace</li>
<li>Lauren Lindsey Donzis</li>
<li>Nasim Pedrad</li>
<li>Izabela Vidovic</li>
<li>Lexi Underwood</li>
<li>Cedric Joe</li>
<li>Emily Marie Palmer</li>
<li>Malcolm Barrett</li>
</ul>
<p>If you want more spooky, age-appropriate adventures, check out our guide to <a href="https://www.thedigitalfix.com/best-scary-movies-for-kids" rel="noopener">scary movies for kids</a>.
</p>
</div>
</article>
<div class="post_footer">
<div class="game_info_panel">
<div class="game_info_readmore">
<span class="readmore_title">More from The Digital Fix</span>
<ul>
<li><a href="/physical-media-streaming-services?driver=mgg" target="_blank" title="Physical media won't save us from streaming services"><p>Physical media won't save us from streaming services</p></a></li><li><a href="/disney-plus/worlds-biggest-streaming-service?driver=mgg" target="_blank" title="Disney is now the world's biggest streaming service"><p>Disney is now the world's biggest streaming service</p></a></li><li><a href="/disney-plus/princess-and-the-frog-disney-plus?driver=mgg" target="_blank" title="The Princess and the Frog gets Disney Plus TV spin-off"><p>The Princess and the Frog gets Disney Plus TV spin-off</p></a></li><li><a href="/best-disney-plus-movies?driver=mgg" target="_blank" title="The best Disney Plus movies of all time"><p>The best Disney Plus movies of all time</p></a></li><li><a href="/disney-plus/muppets-haunted-mansion-first-look?driver=mgg" target="_blank" title="Muppets Haunted Mansion first look reveals Kermit and Miss Piggy's costumes for Disney Plus special"><p>Muppets Haunted Mansion first look reveals Kermit and Miss Piggy's costumes for Disney Plus special</p></a></li><li><a href="/disney-plus/series-about-remaking-the-goonies?driver=mgg" target="_blank" title="Series about remaking The Goonies heading to Disney Plus"><p>Series about remaking The Goonies heading to Disney Plus</p></a></li> </ul>
</div>
</div>
<div class="constellation_promoted_iframe" contenteditable="false" data-regions="US" data-devices="Android" data-embed-id="46033"></div><div class="constellation_promoted_iframe" contenteditable="false" data-regions="US|CA|AU" data-devices="Windows" data-embed-id="45909"></div>
<div class="entry-meta end-of-post">
<div class="author-avatar">
<img alt="" class="avatar avatar-50 photo avatar-default" height="50" src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/01/v2-charlotte-digital-fix.jpg" width="50"> </div>
<div class="entry-meta-details with-bio">
<p class="name-title">
<a class="link-author" href="https://www.thedigitalfix.com/author/charlotte-colombo" rel="author">
Charlotte Colombo </a>
</p>
<p class="author-meta-bio">
Chronically online. Official Staff Writer and unofficial TikTok, <a href="https://www.thedigitalfix.com/the-boys">The Boys</a>, <a href="https://www.thedigitalfix.com/marvel-cinematic-universe/">MCU</a>, and <a href="https://www.thedigitalfix.com/best-streaming-services">streaming service</a> expert. Past bylines include Business Insider, VICE, Rolling Stone, NBC, The Independent and more. </p>
</div>
</div>
<script class="hidden_meta" data-page-type="post">var permutiveSchema = {"schema":{"page":{"content":{"headline":"Just Beyond season 2 release date speculation, plot, cast, and more","type":"guide","category":"disney-plus"},"user":{"loginstatus":false},"game":{"publisher":"","genre":"Disney Plus","title":"Disney Plus","genres":["Disney Plus","TV","Movies"]}}}}</script><div class="BeOpWidget" data-name="below-article"></div> </div>
<div class="sidebar-right">
<div class="posts-showcase sidebar-post-list" data-estimated-height="325" data-sidebar-priority="1">
<span class="widget-title">Popular now</span>
<ul>
<li>
<a href="/the-lord-of-the-rings/rings-of-power-sauron-explained?driver=popular-now" title="Rings of Power: Sauron explained " target="_blank">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/09/rings-of-power-sauron-explained-330x185.jpg" alt="Rings of Power: Sauron explained ">
<span class="sidebar-post-title">Rings of Power: Sauron explained </span>
</a>
</li>
<li>
<a href="/game-of-thrones/house-of-the-dragon-rhaenys-targaryens-dragon-meleys?driver=popular-now" title="House of the Dragon: Rhaenys Targaryen’s dragon Meleys explained " target="_blank">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/house-of-the-dragon-rhaenys-dragon-meleys-explained-4-330x185.jpg" alt="House of the Dragon: Rhaenys Targaryen’s dragon Meleys explained ">
<span class="sidebar-post-title">House of the Dragon: Rhaenys Targaryen’s dragon Meleys explained </span>
</a>
</li>
<li>
<a href="/the-lord-of-the-rings/rings-of-power-valinor-explained?driver=popular-now" title="Rings of Power: Valinor explained " target="_blank">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/rings-of-power-what-is-valinor-330x185.jpg" alt="Rings of Power: Valinor explained ">
<span class="sidebar-post-title">Rings of Power: Valinor explained </span>
</a>
</li>
</ul>
</div>
<div class="static_mpu_wrap" data-estimated-height="600" data-sidebar-priority="1"><div class="ad" id="nn_mpu1"></div></div><div class="sidebar_affiliate_disclaimer">
Network N Media earns commission from qualifying purchases via Amazon Associates and other programs. We include affiliate links in articles. <a href=/terms-and-conditions>View terms</a>. Prices correct at time of publication. </div><div class="posts-showcase sidebar-post-list" data-estimated-height="325" data-sidebar-priority="3">
<span class="widget-title">More stories</span>
<ul>
<li>
<a href="/the-lord-of-the-rings/rings-of-power-sauron-reveal-wasnt-meant-to-be-a-surprise?driver=popular-now" title="Rings of Power Sauron reveal wasn’t meant to be a surprise " target="_blank">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/rings-of-power-showrunner-responds-to-sauron-reveal-330x185.jpg" alt="Rings of Power Sauron reveal wasn’t meant to be a surprise ">
<span class="sidebar-post-title">Rings of Power Sauron reveal wasn’t meant to be a surprise </span>
</a>
</li>
<li>
<a href="/the-lord-of-the-rings/rings-of-power-gil-galad-explained?driver=popular-now" title="Rings of Power: the Elven king Gil-Galad explained " target="_blank">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/rings-of-power-gil-galad-explained-6-330x185.jpg" alt="Rings of Power: the Elven king Gil-Galad explained ">
<span class="sidebar-post-title">Rings of Power: the Elven king Gil-Galad explained </span>
</a>
</li>
<li>
<a href="/the-lord-of-the-rings/rings-of-power-king-durin-the-elves-mithril?driver=popular-now" title="Rings of Power: why did King Durin refuse to give the Elves Mithril? " target="_blank">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/10/rings-of-power-why-did-durin-refuse-to-give-the-elves-mithril-330x185.jpg" alt="Rings of Power: why did King Durin refuse to give the Elves Mithril? ">
<span class="sidebar-post-title">Rings of Power: why did King Durin refuse to give the Elves Mithril? </span>
</a>
</li>
</ul>
</div>
<div class="end">
<div class="static_mpu_wrap" data-estimated-height="680" data-sidebar-priority="1"><div class="ad" id="nn_mpu2"></div></div>
<div class="game-guides sidebar-post-list" data-estimated-height="680" data-sidebar-priority="8">
<span class="widget-title">More from The Digital Fix</span>
<span class="widget-text">Follow us for daily movie and TV news on <a href="http://go.thedigitalfix.com/Facebook">Facebook</a>, <a href="http://go.thedigitalfix.com/Twitter">Twitter</a>, and <a href="http://go.thedigitalfix.com/GoogleNews">Google News</a>.</span>
</div>
<div class="end-global-posts sidebar-post-list ">
<ul>
<li>
<a href="https://www.thedigitalfix.com/best-movies?driver=end-global-posts" target="_blank" title="The best movies of all time">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2021/06/parasite-best-movie-300x180.jpg" alt="The best movies of all time" class="thumbnail">
<span class="sidebar-post-title">The best movies of all time</span>
</a>
</li>
<li>
<a href="https://www.thedigitalfix.com/best-tv-series?driver=end-global-posts" target="_blank" title="The best TV series of all time">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/06/best-TV-series-300x180.jpg" alt="The best TV series of all time" class="thumbnail">
<span class="sidebar-post-title">The best TV series of all time</span>
</a>
</li>
<li>
<a href="https://www.thedigitalfix.com/best-netflix-movies?driver=end-global-posts" target="_blank" title="The best Netflix movies">
<img src="https://www.thedigitalfix.com/wp-content/sites/thedigitalfix/2022/09/Best-Netflix-movies-300x180.jpg" alt="The best Netflix movies" class="thumbnail">
<span class="sidebar-post-title">The best Netflix movies</span>
</a>
</li>
</ul>
</div>
</div> <script>
        console.log("Sidebar type: gameguides_sidebar");
    </script>
</div>
</div>
<footer class="site-footer">
<div class="container">
<div class="footer-brand">
<span class="footer-copyright">&copy; 2022</span>
<span class="brand-networkn">Powered by Network-N</span>
</div>
<ul class="footer-links">
<li><a href="https://www.thedigitalfix.com/terms-and-conditions">Terms and conditions</a>
<li><a href="https://www.thedigitalfix.com/about-us">About us</a>
<li><a href="https://www.thedigitalfix.com/careers">Careers</a>
</ul>
</div>
</footer>
<script>
    var constellation_deals_formats = 'Headphones|Home Cinema & Entertainment Tech|DVD & Blu-Ray|DVD|TVs';
    var constellation_deals_rows = '10';
    var constellation_deals_mindiscount = '1';
    </script>
<script defer src="https://constellationv2.network-n.com/shared/constellation-deals.js?cacheflag=10"></script>
<link rel="preload" href="https://constellationv2.network-n.com/shared/constellation-deals.css?cacheflag=10" as="style" onload="this.onload=null;this.rel='stylesheet'" />
<noscript><link rel="stylesheet" href="https://constellationv2.network-n.com/shared/constellation-deals.css?cacheflag=10"></noscript>
<div class="nn_skinl ad" id="nn_skinl"></div><div class="nn_skinr ad" id="nn_skinr"></div><link rel="stylesheet" href="https://constellationv2.network-n.com/shared/constellation-core.css?cacheflag=20220703"><script defer src="https://constellationv2.network-n.com/shared/constellation-core.js?cacheflag=20220703"></script><div class="js-ifs-nextpage articles_container">
<div class="loading"><div class="loading-text"></div>
<svg class="spinner" viewBox="0 0 50 50"><circle class="path" cx="25" cy="25" r="20" fill="none" stroke-width="5"></circle></svg>
</div>
</div>

<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="thedigitalfix.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<script type="text/javascript">
    var main_css = document.createElement('link');
    main_css.rel = 'stylesheet';
    main_css.href = 'https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/styles/main.f1af1005.css';
    main_css.type = 'text/css';
    let linkTags = document.getElementsByTagName('link');
    var main_css_target = linkTags[(linkTags.length)];
    var main_css_target = document.getElementsByTagName('link')[0];
    main_css_target.parentNode.insertBefore(main_css, main_css_target);
    </script>
<link rel="stylesheet" href="/wp-content/plugins/binnsy-bar/dist/css/style.min.css"><script defer src="/wp-content/plugins/binnsy-bar/dist/js/script.min.js"></script> <style>
        #nn_skinr,
        #nn_skinl {            
            left: 50%;
            z-index: 100;
            padding-top: 80px;
        }
        #nn_skinl {
            width: 300px;
            text-align: right;  
        }
        
    </style>
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-advertising-atlasastro/dist/css/app.e7553135.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-affiliates/dist/css/app.b021ca3b.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/post-types.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/jquery-ui.min.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/nn-images.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/featherlight/featherlight.gallery.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/featherlight-overrides.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/css/wp-featherlight.css">
<link rel="stylesheet" href="https://www.thedigitalfix.com/wp-content/plugins/nn-images/gallery.css">
<script type='text/javascript'>
/* <![CDATA[ */
var teadsConfig = {"page":"","placement":""};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-advertising-atlasastro/dist/js/app.e7553135.min.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var affiliate_data = {"post_id":"47383"};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-affiliates/dist/js/app.b021ca3b.min.js"></script>
<script src="https://www.thedigitalfix.com/wp-includes/js/jquery/jquery.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-includes/js/jquery/jquery-migrate.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-post-types/post-types.js?nc140420"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-includes/js/jquery/ui/core.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/jquery-ui.min.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var legion_games = {"ajax_url":"https:\/\/www.thedigitalfix.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion_games/js/legion-games.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/mce-table-buttons/mobile_tables.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ifs_data = {"target_container":".js-ifs-nextpage","ordering":{"home":["home-normal"],"game":["game-normal"],"article":["19114","600","16626","14687","16413","article-specified","game-normal"]},"flow_type":"article","author_name":"","pid":"47383","paged":"2","homepage":"","search_keyword":"","gametype":"","month":"0","year":"0","taxonomyvalue":"","taxonomy":"","ignore_post_ids":[]};
/* ]]> */
</script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/new-infinite-scroll/dist/js/app.db2ef2fa.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/nn-images.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/legion-pagespeed/js/lazysizes.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/jquery.detect_swipe.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/featherlight.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/vendor/featherlight.gallery.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/wp-featherlight/js/wpFeatherlight.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/main-a3663ec398.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/custom-864e8f7db4.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/mobile-d1831e3a57.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/legion/dist/scripts/video-346cc4fdc0.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/themes/thedigitalfix/dist/./js/main.f1af1005.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/hammer.min.js"></script>
<script defer="defer" src="https://www.thedigitalfix.com/wp-content/plugins/nn-images/gallery.js"></script>
</body>
</html>
